
Acrobat PDF Forms - Part 3
This lesson guides you through the creation of an order form. You will be provided with a Word docu-
ment named Order Form. You will convert this document to an Adobe Acrobat (PDF) document from 
either Word 2003 or Word 2007 (refer to Part 2 in this series for instructions for converting Word docu-
ments to PDF). Part of the form field outlines will be provided by the Word file that has had a small table 
inserted.  In other areas, you will create form fields with outlines. Most of the form fields will be text, 
and you will be guided through duplicating fields, validating text/numeric fields, and calculating numeric 
fields.

Create the first text field
1.	 With your form document opened in Adobe Acrobat 7 Professional, show the Forms Toolbar.
2.	 Choose the Text Field tool, and move your cursor to the first column under the heading Item  

Description.
3.	 Position the cursor at the upper left of the 

top empty rectangle, click and drag the 
cursor to the bottom right of the cell. 

4.	 The Text Properties dialog appears with 
the General tab open.

5.	 Name the text field Item and type the tool tip: “Type item description.”
6.	 Choose the Appearance tab.
7.	 Do not set any Borders or Colors. 
8.	 Set the Font size at 10 and click the Close button.

Duplicate fields
1.	 Click to select the text 

form field you have 
just created.

2.	 Right-click (Windows) 
or Control-click (Mac) 
the form field.

3.	 On the drop-down 
context menu, select 
Create Multiple  
Copies.

4.	 The Multiple Fields 
dialog displays.

5.	 If necessary, click the 
Preview checkbox 
to view the duplicate 
fields.

6.	 For Copy selected fields down, enter 10.
7.	 For Copy selected fields across, enter 1.
8.	 You can use the Overall Size (All Fields) to adjust the amount of space between each field affected 

by the duplication. Additionally, use the Overall Position (All Fields) to move the field being du-
plicated and all the copies. If all the fields are either too high or too low within each cell, click the 
Down or Up button to move the fields on the page. Click the OK button to close the window.



8.	 Double-click the original form field that was duplicated, and click the General tab. Note that Adobe 
Acrobat added a period and number following the form field name. Click the Close button.

See above a screen picture of the duplicated fields: 
Item Description, Price Each, Quantity, and Item 
Total. 

See at right, the duplicate fields dialog, showing the 
settings that were used to duplicate the fields under 
Item Description.

When fields are duplicated using this method, 
Adobe Acrobat automatically renames each field so 
that it is unique by adding a consecutive number at 
the end of each form field name. It is not, therefore 
necessary to rename each of the duplicate fields.

Validating Text/Numeric Fields
To ensure that correct information is entered into 
form fields, use Acrobat’s field validation feature. 
For example, if a response needs to be a number 
with a value between 10 and 20, you can restrict 
entries to numbers within this range. Here you will 
limit the price of each item to no more than $2,000.

1.	 From the Forms toolbar, select the Text Field tool.
2.	 In the Order Form table, move your cursor to the second column from the left with the heading of 

Price Each.
3.	 Position the crosshairs at the upper left corner of the first empty cell at the top of this column. Click 

and drag downward and to the right to create a field that fills the cell. 
4.	 On the General tab of the Text Field Properties window, for Name, enter Price and for Tooltip, 

enter Price per item.
5.	 Click the Appearance tab, and for font size, choose 10.
6.	 Click the Options tab, and for Alignment, choose Center.



7.	 Click the Format tab and set the following:
	 For Select format category, choose Number.
	 For Decimal Places, choose 2.
	 For Separator Style, choose 1,234.56 (the default).
	 For Currency Symbol, choose Dollar ($).
8.	 Click the Validate tab, then choose the radio button to select Field value is in range. In the range 

fields, enter a value of 0 into the From field and 2000 for the To field.
9.	 Click the Close button to close the Text Field Properties window.
10.	Right-click (Windows) or Control-click (Mac) the text field (Price) you have just created, and follow 

the previous instructions for creating multiple copies of this field.

Another numeric field (Quantity)

Formatting is a method for making sure that data entered into form fields is appropriate. By specifying a 
field’s contents as a number, you can prevent users from entering letters or any other characters.

1.	 If necessary, select the Text Field tool.
2.	 Move the cursor to the third column, with the heading Quantity.
3.	 Create the top form field and on the General Tab name it Quantity.
4.	 For the Tooltip, enter “Type the quantity.”
5.	 On the Appearance tab, for font size, choose 10.
6.	 Click the Options tab, for Alignment, choose Center, or you may prefer another alignment setting.
7.	 Click the Format tab, and set the following:
	 For Select format category, choose Number

	 For Decimal Places, choose 0.
	 For Separator Style, choose 1,234.56.
	 For Currency Symbol, choose None.
8.	 Duplicate this field down the column, as previously instructed.

Calculating Numeric Fields
1.	 With the Text Field tool in the top cell under Item Total, draw from the upper left to lower right to 

create a text field.
2.	 In the General tab, name the field Total.
3.	 For the Tooltip, type “This field will be calculated.”
4.	 In the Appearance tab, set the font size at 10.
5.	 Click the Options tab, for Alignment, choose Center, or you may prefer another alignment.
6.	 On the Format tab, set the following:
	 For Select format category, choose Number

	 For Decimal Places, choose 2.
	 For Separator Style, choose 1,234.56.
	 For Currency Symbol, choose Dollar Sign.
7.	 Click the Calculate tab and set the following:
	 Select the Value is (the radio button) 
	 Choose Product (x) of the following fields
8.	 Press the Pick button. The Field Selection window displays a listing of fields that can be used in the 

calculation. In the Field Selection window, check the boxes to the left of  Price.0 and Quantity.0.
9.	 Click the OK button to close the Field Selection window.
10.	Click the Close button to close the Text Field Properties window.
11.	Duplicate this field, as previously explained.



Note: When you duplicate this field, the name of the field will be changed, as it was in the previous col-
umns. The top field will be named Total.0, and so on down the column. You will now have to correct the 
calculations on all the total fields except the first one.

Correct the calculations in all the duplicate fields
1.	 If necessary, select the Text Field Tool.
2.	 Double-click to open the Total.1 field (or Right+Click (WIN) or Control+Click (MAC) and select 

Properties on the Context menu).
3.	 If necessary, click the Calculate tab.
4.	 Click Pick.
5.	 In Field Selection window, 

click the box to the left of 
Price.1 and box to the left of 
Quantity.1. Click to remove the 
checks at the left of Price.0 and 
Quantity.0 and click OK.

6.	 In the Total.2 field, double-click 
to open the Text Properties 
dialog, and if necessary click on 
the Calculate tab.

7.	 Click Pick.
8.	 In the Field Selection win-

dow, delete the selections in 
the boxes at the left of Price.0 
and Quantity.0 and click in the 
boxes of Price.2 and Quantity.2. 
In the illustration at right, see 
the Field Selection window in 
which the Price.3 and Quan-
tity.3 fields have been checked. 

9.	 Continue down the column, 
making sure that each total field 
includes a calculation that is the 
product of the Price and Quan-
tity in its row. For example, the 
Total.3 field should include a 
calculation of the product of 
Price.3 and Quantity.3, and so 
on, ending with the Total.10 
field.

10.	Look at the screen picture of 
the Calculate tab at the right 
that shows the calculation of the 
product of Price.10 and Quan-
tity.10.

Do not format the last field in the 
Item Total column.



Format the Order Total field.
1.	 With the Text Field Tool, 

double-click to open the Or-
der Total field (or Right-click 
(WIN) or Control-Click (MAC)  
the field and choose Properties 
on the Context menu)..

2.	 Click the Calculate tab.
3.	 Look at the illustration at the 

right.
4.	 Select the Value is the radio 

button and choose sum (+) of 
the following fields.

5. Click Pick button. 
6.	 The Field Selection window 

displays a listing of all the Item 
Total fields. See the Calculate 
tab at the right showing the set-
tings.

7.	 When finished, click the Close 
button.

Completing the 
form fields

Using the Text Form 
Field Tool, draw 
fields following 
Name, Street, City, 
State, Zip, Country, 
Daytime Phone, 
Email, Type of Pay-
ment, Card Number, 
and Expiration Date. 

These fields will have 
a solid border outline 
around them. On the 
Appearance Tab: Set 
a color for the border, 
set line thickness at 
thin and line style at 
solid.

Using the Button tool, create a Print button and a Reset button in the lower right area of the form. 

If you can’t remember how to create these buttons, please refer to the PDF Forms Part 2 lesson guide, 
pages 3 and 4.



Define Tab Order

If a PDF document is not tagged and doesn’t have a specified tab order, the 
order in which the form fields were created determines their tabbing order. 
If a PDF document is tagged, the document structure determines the form 
fields’ tabbing order. You can use the Tab Order options in the Page Prop-
erties to set the tab order of form fields by the row, column, or document 
structure. If your form is not set up in rows or columns, then you can manu-
ally customize the tab order by using the Set Tab Order command.

Set Tab Order by Row
1.	 Notice in the Order Form that the top section is organized 

by Row. You will set the tab order by row for that section 
of the form.

2.	 See above right, a picture of the Navigation tab with the 
page showing.

3.	 If the Navigation pane is not showing, pull down the View 
menu and select the Navigation tab, then in the sub-menu, 
select Pages.

3.	 With the Page selected in the Navigation tab, click the 
Down arrow at the right of Options..

4.	 On the drop-down menu, choose Page Properties. 
5.	 On the Tab Order dialog, select Row Order.
6.	 Your form now has a tab order by row order, which is fine 

for the top section. However, for the bottom area of the 
form, the row order is not what you want.

Set Tab Order for the bottom portion of the form
1.	 Open Page Properties.
2.	 In the Tab Order dialog, select Unspecified, then click Close.
3.	 In Adobe Acrobat, click Advanced, then Forms, then Edit Fillable Forms.
4.	 A dialog displays, and you will select Acrobat’s Forms Tools.
5.	 Choose Advanced, then Forms, then Fields, and then 

Set Tab Order.
6.	 Look at the tab order. The top section has the tab 

order by row. Leave that section alone.
7.	 Click in the Name field with your cursor.
8.	 Click and continue to click until the number in that 

field is one number higher than the last form number 
in the Order Total field.

9.	 Click in the Street field, and click until the number 
in that field is one number higher than the previous.

10.	Continue down the lower left fields and then the 
three fields at the lower right, incriminating the form 
field tab set numbers.

11.	When finished, save the form.



Fill out the Order Form
If a PDF form contains interactive form fields, you can fill in the form with the Basic toolbar’s Hand 
tool. If you have successfully set the tab order, then you can advance forward through the form using the 
Tab button. You can go backward, using the Shift+Tab keys. If you want to select a certain form field, 
use the Hand tool pointer and point to the form field and click.

If you want to make form fields easier to identify, you may want to display a light blue color in the back-
ground of all form fields. If so, select Highlight Fields in the Document Message Bar.

When users opens forms containing interactive form fields in Acrobat Reader, they can fill in the forms 
and then print them. They cannot save them or modify them. The Adobe Reader can be downloaded 
from the Adobe web site free of charge.  

Users must open the Adobe Acrobat form using the Adobe Acrobat program (not the Reader) in order to 
save the form. Such users may or may not be able to modify the form, depending on the document secu-
rity settings set by the creator of the form.
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